Help

Old Technology

Believe it or not, this is old technology. 🙂

In fact, awesome 3D on the web has been around for over a decade, but there were things holding back its popularity. This site has been around a decade, and it looks as though it’s time we update the technology, as the plugin we’re using no longer supports the vast majority of visitors. It actually did at one time.

Your Browser


Looks like you’re running: unknown unknown on unknown.

Last we heard, the plugin supported the following:

Windows (NT-based only): IE 6+, AOL 7+, and FireFox 2.x (NOT FireFox 3+)
MAC (OS X 10.4 and 10.5 only): Safari 2+ and FireFox 2.x (NOT FireFox 3+)

In other words, if you’re on Windows, switch to IE and you’ll get a prompt to install the plugin. Then you can check out the 3D. We’ve successfully tested up to Windows 7 on 32 & 64 bit machines with IE 8.

If you’re on Mac using OS X 10.4 (Tiger) or 10.5 (Leopard), try Safari. We can’t guarantee it will work, but let us know if you have issues. If enough people have issues with a certain browser, we’ll remove it from our install script. It may work with a later version of Mac as well. We simply don’t know, as we don’t have the information from the plugin manufacturer, and we don’t have a Mac test center.

Other operating systems aren’t supported. Hopefully this won’t be an issue much longer, as we plan to move to a different technology soon.

Viewpoint

Information about the 3D plugin, direct download, FAQ, system requirements, etc.